View: 628|Reply: 8

4G/LTE issue

[Copy Link]
Posted at 2017-10-1 00:38:34 | All floors |Read mode
Last edited by Sam In 2017-10-1 00:39 Editor

Hello,

My phone is stuck on Rogers/Fido 3G network (Canada)...

I only saw twice the phone connecting to the 4G but when this happened I was unable to use the data at all.

I've already done a factory reset but it didn't fix the issue. I bought this phone because it was 4G compatible and the frequencies used for LTE on this carrier are supported by the phone.

Is my phone deffective?
Reply

Use props Report

Posted at 2017-10-1 12:59:30 | All floors
I am a Fido customer in Toronto and I'm seeing 3G as well.  Only tried it at home.  This is disappointing.  Hope there is a solution.
Reply Support Opposition

Use props Report

 Author| Posted at 2017-10-2 00:32:56 | All floors
Last edited by Sam In 2017-10-2 00:34 Editor

So I don't know if this is good news but at least it proves that my phone is not "deffective"... What is so frustrating is that I bought this phone exclusively because it was 4G/LTE compatible... But in reality it seems to not be...

I want a refund!
Reply Support Opposition

Use props Report

Posted at 2017-10-2 03:52:42 | All floors
Last edited by VitaminC In 2017-10-2 03:53 Editor

I still haven't taken the Jelly Pro out of the house but made the changes to the APN found here.  Now it is connecting at 4G while at home.  That's an improvement.  If you're not on Fido, I guess Rogers must have something similar.

http://www.fido.ca/consumer/cont ... locked-device-guide

Edit: The important part.

Please insert the following APN settings:APN Settings:
  • APN: Fido-core-appl1.apn
  • If you have a LTE device, use the following setting: LTEMOBILE.APN
Reply Support Opposition

Use props Report

 Author| Posted at 2017-10-3 00:08:23 | All floors
Thanks VitaminC. I'll give it a try. I rarely had to play with APN settings before and I'm always buying my phones unlocked. Anyway we'll see. I'll keep you posted.
Reply Support Opposition

Use props Report

 Author| Posted at 2017-10-3 09:18:35 | All floors
So that was it... I just needed to enter manually the APN for LTE... Now the phone display a 4G and data works perfectly...

The only issue now is the battery...

Thanks VitaminC!

PS: if you get 4G at home I don't see why it wouldn't work outside...
Reply Support Opposition

Use props Report

Posted at 2017-10-4 08:52:56 | All floors
Happy that it worked for you.  I have taken it outside now and seems to be working fine.  Battery life is not the greatest but when I left the house with it, it wasn't fully charged.  Need to keep my eye on it more than I should need to, I guess.  For now it's the phone to carry when I don't plan on using a phone.  Not even sure why I bought this, my eyes are getting to the point where the text is too small to be comfortable.
Reply Support Opposition

Use props Report

Posted at 2017-10-10 17:49:07 | All floors
Dear Sam and VitaminC,
                                                I think you can provide the APN settings parameter so that Unihertz will port them into next software version, thanks.
Reply Support Opposition

Use props Report

Posted at 2017-10-14 08:19:55 | All floors
How do I provide the APN settings for my provider?
MTS.ca
https://www3.bellmts.ca/mts/supp ... non-bellmts+devices
Reply Support Opposition

Use props Report

You need to log in before you can reply Login | Register now

This forum Credits Rules

Quick Reply Back to top Back to list